Trello is slow or unavailable
Incident Report for Trello
Resolved
Our engineers have fully resolved the issue and all trello.com services have been fully restored. If you're still having any trouble, please don't hesitate to reach out via https://trello.com/contact
Posted 4 months ago. Jun 04, 2018 - 18:49 UTC
Monitoring
Our engineering team is confident they've located the problem, and are continuing to monitor trello.com's performance.
Posted 4 months ago. Jun 04, 2018 - 15:15 UTC
Investigating
Trello is currently slow or unavailable.

Our engineering team is actively investigating this incident and working to bring Trello back up as quickly as possible.

Users affected by this incident may notice that Trello is slow or completely unavailable in both the web and mobile apps.

We will update this page as we have additional information.
Posted 4 months ago. Jun 04, 2018 - 14:44 UTC
This incident affected: Website and API.