Some users are having difficulty connecting to Trello
Incident Report for Trello
Resolved
This incident has been resolved.
Posted 7 months ago. Apr 21, 2017 - 20:25 UTC
Monitoring
Connection trouble for most customers should be cleared up, but Trello engineers are continuing to monitor the situation, and working with our CDN partner on a complete resolution.
Posted 7 months ago. Apr 20, 2017 - 20:52 UTC
Identified
Working with our CDN partner to resolve the underlying issue. Most users should have access to Trello again.
Posted 7 months ago. Apr 20, 2017 - 19:13 UTC
Update
Trello engineers are continuing to investigate this incident and are working towards a resolution. Connection interruptions are intermittent at this time.
Posted 7 months ago. Apr 20, 2017 - 19:03 UTC
Investigating
Some users are reporting connection issues when trying to load Trello.com

Akamai, our CDN, is experiencing issues and working to resolve it.

Next update within 15 minutes.
Posted 7 months ago. Apr 20, 2017 - 18:50 UTC