Live updates are incomplete
Incident Report for Trello
Resolved
Live updates to Trello boards are working as expected again. From approximately 2:30pm ET until 3:22pm ET, they may have been incomplete. No edits were lost, but other users looking at the same board might not see those edits until the board is refreshed.
Posted about 1 year ago. Sep 18, 2017 - 19:33 UTC
Investigating
Trello users may see that live updates to boards are currently incomplete, and boards may appear out-of-sync if other people are editing the board.

Our engineers are working to resolve the problem as soon as possible.
Posted about 1 year ago. Sep 18, 2017 - 18:58 UTC