Help Docs currently unavailable
Incident Report for Trello
Resolved
All third-party outages have been resolved and http://help.trello.com Help Docs are accessible again.
Posted 5 months ago. Jul 10, 2017 - 17:56 UTC
Monitoring
Due to a third party outage, Trello's Help Docs at http://help.trello.com are currently unavailable, but will return once that outage is resolved. Our team is monitoring the situation.
Posted 5 months ago. Jul 10, 2017 - 17:09 UTC