Trello is slow or unavailable
Incident Report for Trello
Resolved
Our engineering team has been monitoring the situation, and all Trello services are stable. If you're still having any trouble, please don't hesitate to reach out via https://trello.com/contact!
Posted 10 months ago. Mar 02, 2018 - 18:34 UTC
Monitoring
Our engineering team has pushed a fix, and we expect that full Trello functionality is now resolved. If you're still having any trouble, please don't hesitate to reach out via https://trello.com/contact!
Posted 10 months ago. Mar 02, 2018 - 16:03 UTC
Identified
Some Trello customers may be experiencing Connection Interrupted messages from Trello, while others aren't. Our Engineering team is actively working on a solution.
Posted 10 months ago. Mar 02, 2018 - 15:37 UTC
Investigating
Trello is currently slow or unavailable.

Our engineering team is actively investigating this incident and working to bring Trello back up as quickly as possible.

Users affected by this incident may notice that Trello is slow or completely unavailable in both the web and mobile apps.

We will update this page as we have additional information.
Posted 10 months ago. Mar 02, 2018 - 15:24 UTC