Trello Search not working
Incident Report for Trello
Resolved
Trello Search services have been restored. If you continue to have any trouble, don't hesitate to reach out via https://trello.com/contact!
Posted 8 months ago. Apr 30, 2018 - 16:33 UTC
Investigating
Trello Search is currently down, and our Engineering team is working to restore it as soon as possible!
Posted 8 months ago. Apr 30, 2018 - 15:42 UTC