Trello was unreachable momentarily
Incident Report for Trello
Resolved
This incident has been resolved.
Posted 3 months ago. Mar 14, 2017 - 17:12 EDT
Monitoring
At around 10:50am EST, Trello.com was unreachable for users for around 60 seconds. Service has been restored, and we are monitoring the situation. If any additional information becomes available, we will update here.
Posted 3 months ago. Mar 14, 2017 - 10:58 EDT