Trello is slow
Incident Report for Trello
Resolved
Trello.com is loading normally again, but our Engineers are keeping an eye on its performance. If you do continue to have any trouble, don't hesitate to reach out via https://trello.com/contact and we'll be glad to help!
Posted about 1 year ago. Dec 10, 2017 - 10:11 UTC
Update
Our Engineering team is continuing to identify the cause behind Trello's slowness, though we're seeing boards begin to load normally again. Thanks for your patience!
Posted about 1 year ago. Dec 10, 2017 - 09:45 UTC
Investigating
Some users may get slow response times while using Trello.

Our engineering team is actively investigating this incident and working to bring Trello back up to speed as quickly as possible.

We'll keep you posted with further updates on this page.
Posted about 1 year ago. Dec 10, 2017 - 09:18 UTC