Notification emails delayed
Incident Report for Trello
Resolved
All Trello notification email delays have been resolved and messages reception times are back to normal. If you're still having trouble, don't hesitate to reach out at https://trello.com/contact!
Posted 11 days ago. Sep 12, 2017 - 18:40 UTC
Monitoring
Outgoing notification emails have caught up, and our engineering team is monitoring the queue moving forward.
Posted 11 days ago. Sep 12, 2017 - 15:04 UTC
Investigating
Notification emails from Trello are currently being sent, but are delayed. Our engineers are investigating the problem.
Posted 11 days ago. Sep 12, 2017 - 14:33 UTC